08 APR 2022 1420 UTC-5 - Spring4Shell Vulnerability announced CVE-2022-22965.
Release 2.6.20 software is released and available for download. For details Click here.
If you have any questions or concerns, please email Ramp support [email protected] or call Toll Free +1 877 870 3742
Click X to close this banner.